Reset Search
 

 

Article

Installing extensions in Atmel Studio shows 'This extension is not installable on any currently installed products.'

« Go Back

Information

 
Question
When installing extensions in Atmel Studio, I get an error message saying
This extension is not installable on any currently installed products.

This happens when running .vsix files directly, not when using the extension manager built into Atmel Studio.
Answer
Between Visual Studio 2010 and Visual Studio 2015, Microsoft changed how extensions are registered into the system. Since Atmel Studio 6 and AVR Studio 5 is based on Visual Studio 2010, and Atmel Studio 7 is based on Visual Studio 2015, there might be problems installing extensions due to the default file association for .vsix files. 

If the file association was done by AVR Studio 5 or Atmel Studio 6, then the extension installer for Visual Studio 2010 will try to install the extension, but it will be unable to do it due to the changes done in Visual Studio 2015. 

To change the file association
  1. Right click on the VSIX file and select 'Open with', and then 'Choose default program'.
  2. Click the 'Browse' button (Windows 7) or click on 'More' and 'Look for another app on this PC' (Windows 8 and newer).
  3. Browse to VSIXInstaller.exe located in C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE

Using this installer, you should be able to install both Atmel Studio 7 extensions, as well as Atmel Studio 6, AVR Studio 5 and Visual Studio extensions.

Attachment(s) 

Feedback

 

Was this article helpful?


   

Feedback

Please tell us how we can make this article more useful.

Characters Remaining: 255